Add Unit Test for Schema fails

May 11, 2011 at 5:53 PM

I am trying to use BSF which seems a great idea!

I added a new schema to my schemas project, the tried to run the recipe to add a unit test for it, but after the target selection, the pull down to select a schema shows an error mark and the output windows displays the following:


Output window created.
SchemaProject - GetSchemaList : Begin
SchemaProject - GetSchemasFromProjectFolder : Begin
SchemaProject - GetSchemasFromProjectFolder : End
SchemaProject - GetSchemasFromProject : Begin
System.NullReferenceException: Object reference not set to an instance of an object.
   at BizTalkSoftwareFactory.BusinessComponents.SchemaProject.GetSchemasFromProject(Project btsProject, List`1 schemaList)
   at BizTalkSoftwareFactory.BusinessComponents.SchemaProject.GetSchemaList(ITypeDescriptorContext context)
   at BizTalkSoftwareFactory.Converters.SchemaConverter.GetStandardValues(ITypeDescriptorContext context)
   at Microsoft.Practices.WizardFramework.ValueEditor.ValueEditorListBox.RefreshListBoxItems()
   at Microsoft.Practices.WizardFramework.ValueEditor.ValueEditorListBox.EndInit()
   at Microsoft.Practices.WizardFramework.ValueEditor.ValueEditorListBox.InitializeComponent()
   at Microsoft.Practices.WizardFramework.ValueEditor.ValueEditorListBox..ctor(ValueEditor valueEditor)
   at Microsoft.Practices.WizardFramework.ValueEditor.EditDropDownBtn(Object sender, EventArgs e)


Maybe there some documentation on this Factory, because I didn't find any.

Thanks for all the help I can get


May 11, 2011 at 5:55 PM

OK, not only I  compiled the schemas project, but I also added the Target Namespace to the schema.


Now it works!


This is awesome